最新openssl漏洞ccs注入及升级修复(OpenSSL CCS vuln. (CVE-2014-0224))

作者: mikj 分类: google, 建站学习, 教程使用, 网络赚钱, 资源分享 发布时间: 2014-06-22 23:49 ė 6没有评论

查看openssl版本

$ openssl version
OpenSSL 1.0.1e 11 Feb 2013

下载安装最新的openssl:
安装需要 zlib库支持 没有的话就装一下

$ wget http://www.openssl.org/source/openssl-1.0.1h.tar.gz
$ tar xvzf openssl-1.0.1h.tar.gz

$ cd openssl-1.0.1h

$ ./config shared zlib   #支持zlib压缩与解压缩,并创建共享库

$ make && make install   #编译安装

备份原来的和配置新的:

mv /usr/bin/openssl /usr/bin/openssl.bak
mv /usr/include/openssl /usr/include/openssl.bak
ln -s /usr/local/ssl/bin/openssl /usr/bin/openssl
ln -s /usr/local/ssl/include/openssl /usr/include/openssl
 
echo "/usr/local/ssl/lib" >> /etc/ld.so.conf
ldconfig -v

最后检测版本

$ openssl version
OpenSSL 1.0.1h 5 Jun 2014

升级over 可以检测一下 https://www.ssllabs.com/ssltest/analyze.html

本文出自 小沨的天空,转载时请注明出处及相应链接。

本文永久链接: http://www.xiaofengsky.com/82526.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注

You must enable javascript to see captcha here!

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Ɣ回顶部